Autor: Peter Haserodt  --- Aus Excel Standard - Gruppe: Tutorials

Funktionen (3) - Verschachtelte Funktionen

Autor: Peter Haserodt - Erstellt: ?      - Letzte Revision: ?Gruppenthema: 3 Folgen 1 2 3 Sie sind in Folge:3
Funktionen in Funktionen - So leicht und doch so schwer

b=c+d
a= b
daraus folgt: a=c+d
oder?
So einfach ist dies aber schauen wir es uns in Ruhe an!

In der nachfolgenden Tabelle wird von zwei Bereichen der Mittelwert gebildet und von diesen der größte dann gesucht.
(Eine Sache die man tagtäglich braucht sm3 (1K) )

 
 ABCDE
1     
2 1 6 
3 2 7 
4 3 8 
5 4 9 
6 5 10 
7     
8 3 8 
9     
10  8  
Formeln der Tabelle
B8 : =MITTELWERT(B2:B6)
D8 : =MITTELWERT(D2:D6)
C10 : =MAX(B8;D8)
 


Ja und was soll uns dies nun sagen?

Erstmal nicht viel, denn daran ist nichts verschachtelt.

In Zelle B8 bilde ich den Mittelwert des gelben Bereiches, in Zelle D8 den des Hellblauen.

Danach ermittle ich mit der Funktion Max den größeren Wert von B8 und D8.

Wir nehmen uns einfach mal ein Stück Papier und schreiben:
Max(a;b)

Denn es ist ja offensichtlich, das wir das Maximum von zwei Werten ermitteln wollen.

Auf das gleiche Stück Papier schreiben wir:
a=Mittelwert(B2:B6) und b= Mittelwert(D2:D6)

Und jetzt kommt das berühmte Einsetzungsverfahren:
In Max(a;b) ersetzen wir das a durch unseren Text für a und b durch unseren Text für b und schon erhalten wir:

Max(Mittelwert(B2:B6);Mittelwert(D2:D6))

Auf unser Beispiel umgemünzt:
Wir hatten Max(B8;D8)
B8 ist der Platzhalter für die Berechnung Mittelwert(B2:B6) und D8 der Platzhalter für die Berechnung Mittelwert(D2:D6)

Aber was quassele ich so lange, Sie haben es ja schon längst:

 
 ABCDE
1     
2 1 6 
3 2 7 
4 3 8 
5 4 9 
6 5 10 
7     
8  8  
Formeln der Tabelle
C8 : =MAX(MITTELWERT(B2:B6);MITTELWERT(D2:D6))
 


Das einfachste der Welt, wie Sie sehen.

Man muss einfach nur den Gedanken wegstreichen, dass Argumente in Funktionen Werte oder Bereiche sein müssen.
Nein, Sie können selbst wieder Funktionen sein - so einfach.

Tatsächlich ist es sehr sinnvoll, solche zusammengesetzten Funktionen am Anfang nach dieser Art aufzubauen.
Also erstmal in Hilfszellen die Einzelfunktionen zu erstellen, in einer weiteren Hilfszelle diese dann mit der nächsten Funktion zusammenzufassen und aus dem Ganzen dann die fertige Formel zu erstellen.

Und ich versprechen ihnen, bei komplexeren Formeln gehe auch ich genau so vor!

Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Dieses Thema hat weitere Beiträge

Funktionen (1) - Grundlagen von Funktionen
Funktionen (2) - Argumente näher beleuchtet
Funktionen (3) - Verschachtelte Funktionen

Weitere Artikel der Gruppe: Tutorials Aus Excel Standard
Nach oben