. NUR
Das Forum wird bald geschlossen
Das ehemalige andere Excel Forum
. .
Excel Jeanie Html

About 10B + 1 R Fragen Wie Fragen? 10B + 1 R Antworten Hilfe !!! DOWNLOADS Links 
Nicht eingeloggt :   Einloggen  Noch keinen Benutzernamen :   Benutzernamen beantragen  Passwort vergessen :   Neues Passwort
Forum <> Neues Thema <> Suche <> Mods

 
Zählen ohne Duplikate im definierten Datumsbereich
Von:  joe cocker  Am: 16.06.2017 14:33:02
Excel 2010 - Lösung bitte nur in Excel (Keine Makros/kein VBA) - vielen Dank
Hallo Forumsteilnehmer,

ich habe folgendes Problem beim Zählen ohne Duplikate bei dem ein Datumsbereich berücksichtigt werden muss. Mit den von mir eingefügten Formeln in F6 und F7 wird ein falsches Ergebnis ermittelt. Die Ursache liegt darin, dass nicht der in F2 und F3 gewählte Datumsbereich ausschließlich zum Zählen ohne Duplikate berücksichtigt wird. Somit werden auch die im Datumsbereich vom 01.01.2017 bis 31.01.2017 aufgeführten Art-Nrn. und Kunden bei der Ermittlung der Duplikate berücksichtigt.

Ich habe das Forum nach einer ähnlichen Fragestellung geprüft, habe jedoch keinen ähnlichen Fall gefunden.
Vielleicht kann mir jemand kurzfristig helfen. Herzlichen Dank.

2017_Rekla (2)

 ABCDEF
1Artikel-Nr.KundeAngelegt am:   
25005053120004.01.2017 Zeitraum von:01.02.2017
35002881111404.01.2017 Zeitraum bis:24.02.2017
45002881111410.01.2017   
55002551162316.01.2017   
65006701192318.01.2017 Anzahl Kunden2
75002191183019.01.2017 Anzahl Artikel-Nr.2
85001621015225.01.2017   
95001221111407.02.2017   
105001221199807.02.2017   
115001621015208.02.2017 Richtig wäre: 
125008241121616.02.2017 Lieferant: 4Artikel: 3
135001221199824.02.2017 10152500122
145006591192301.03.2017 11114500162
155002161137103.03.2017 11216500824
165010481137113.03.2017 11998 
173004903014814.03.2017   
185002881111415.03.2017   
195001221199816.03.2017   
205001621015220.03.2017   
215008241121421.03.2017   
221317101161821.03.2017   
232550001241221.03.2017   
245009423124630.03.2017   
255083101111130.03.2017   
265010971121431.03.2017   
275005001231503.04.2017   
285007341027012.04.2017   
295010041121420.04.2017   
305009331137125.04.2017   
315002523014727.04.2017   
325009282182003.05.2017   
335002441111408.05.2017   
345002441111423.05.2017   

Formeln der Tabelle
ZelleFormel
F6=SUMMENPRODUKT((VERGLEICH($B$2:$B$34;$B$2:$B$34;0)=ZEILE(A1:A33)*($C$2:$C$34>=$F$2)*($C$2:$C$34<=$F$3)*($B$2:$B$34<>""))*1)
F7=SUMMENPRODUKT((VERGLEICH($A$2:$A$34;$A$2:$A$34;0)=ZEILE(A1:A33)*($C$2:$C$34>=$F$2)*($C$2:$C$34<=$F$3)*($A$2:$A$34<>""))*1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

   Antworten  +++  Forum 
Excel verstehen bei: Online-Excel Zum Beispiel: # - Fehlerwerte (aus Excel Standard)



Alle Lesen


Alle Lesen

Forum <> Neues Thema <> Suche <> Mods


Impressum: Impressum - Datenschutz - Forumstechnik: Peter Haserodt - Farbgestaltung: Uwe Küstner
Alle innerhalb des Forums genannten und ggf. durch Dritte geschützten Marken- und Warenzeichen unterliegen uneingeschränkt den Besitzrechten der jeweiligen eingetragenen Eigentümer Alle Beiträge stammen von dritten Personen u. dürfen geltendes Recht nicht verletzen.