. NUR
Das Forum wird bald geschlossen
Das ehemalige andere Excel Forum
. .
Excel Jeanie Html

About 10B + 1 R Fragen Wie Fragen? 10B + 1 R Antworten Hilfe !!! DOWNLOADS Links 
Nicht eingeloggt :   Einloggen  Noch keinen Benutzernamen :   Benutzernamen beantragen  Passwort vergessen :   Neues Passwort
Forum <> Neues Thema <> Suche <> Mods

 
Mittelwert für Jahrestag
Von:  francois75  Am: 06.01.2017 16:25:01
Excel 2010 - Lösung bitte nur in Excel (Keine Makros/kein VBA) - vielen Dank
Hallo allen Hilfsbereiten.
Ich bin neu hier und begehe hoffentlich keinen Faux pas.

Mein Problem.  
In einer Tabelle stehen in Spalte A die Datumswerte für Viertelstunden (z.B. 06.01.2017 00:15) und zwar für alle 35040 Viertelstunden eines Jahres.
In Spalte B stehen die dazu gehörenden Viertelstundenleistungen (es geht um Stromproduktion).

Ich möchte gerne für jeden Tag des Jahres den Mittelwert der jeweils zu ihm gehörenden Viertelstunden ermitteln.

Die folgende Formel bringt mir für eine Viertelstunden den jeweiigen Jahrestag.
=RUNDEN(A2-DATUM(JAHR(A2);1;);0))  
Das gibt für 06.01.2017 00:15 beispielsweise 6 (weil des der 6. Jahrestag ist)


Jetzt habe ich eine Formel gebaut die Monatsmittelwerte ermittelt (habe mich da im Forum inspiriert).  Hier die Ermittlung des Mittelwertes der Leistungen der Viertelstunden des Monats Januar.

=WENNFEHLER(MITTELWERT(WENN((MONAT($A$2:$A$35045)=1)*($A$2:$A$35045<>0);($B$2:$B$35045)));"")

Aber wie stricke ich das um damit ich nicht mehr Monate sondern Jahrestage auswerte ?

Danke für eure Unterstützung und allen ein gutens Jahr 2017.

Gruss,
François

   Antworten  +++  Forum 
Excel verstehen bei: Online-Excel Zum Beispiel: Felder - Einführung (aus Excel VBA)



Alle Lesen


Alle Lesen

Forum <> Neues Thema <> Suche <> Mods


Impressum: Impressum - Datenschutz - Forumstechnik: Peter Haserodt - Farbgestaltung: Uwe Küstner
Alle innerhalb des Forums genannten und ggf. durch Dritte geschützten Marken- und Warenzeichen unterliegen uneingeschränkt den Besitzrechten der jeweiligen eingetragenen Eigentümer Alle Beiträge stammen von dritten Personen u. dürfen geltendes Recht nicht verletzen.