Autor: Peter Haserodt  --- Aus Excel Standard - Gruppe: Funktionen

ODER

Autor: Peter Haserodt - Erstellt: ?      - Letzte Revision: ?Gruppenthema: 3 Folgen 1 2 3 Sie sind in Folge:1
Die ODER Funktion - oder viele Wenns?

Die ODER Funktion ist eine Funktion, die eine logische Aussage zurückgibt, nämlich WAHR oder FALSCH.
Diese Aussage können wir dann in anderen Funktionen weiterverwerten.

Gegeben sei die Aufgabe, 3 Zellwerte auf bestimmte Inhalte zu überprüfen und zu ermitteln, ob mindestens eine unserer Bedingungen zutrifft.

Uns interessiert z.B., ob B2 > 4 oder B3 > 4 oder B4 > 4 ist. Wenn eine dieser Bedingungen zutrifft, wollen wir in D2 das Wort Gut stehen haben, sonst das Wort Schlecht.

Der Wenn Künstler ist natürlich nicht verlegen:
 
 ABCDE
1     
2 3 Gut 
3 5   
4 2   
5     
Formeln der Tabelle
D2 : =WENN(B2>4;"Gut";WENN(B3>4;"Gut";WENN(B4>4;"Gut";"Schlecht")))
 


Ein fürchterlich Ding oder? Kein Mensch blickt mehr durch und wehe es werden noch mehr Bedingungen.

Will ich mehrere Bedingungen überprüfen, von denen eine wahr sein soll, gibt es dafür die ODER Funktion:

 
 ABCDE
1     
2 3 Gut 
3 5   
4 2   
5     
Formeln der Tabelle
D2 : =WENN(ODER(B2>4;B3>4;B4>4);"Gut";"Schlecht")
 

Sieht doch eleganter aus oder?

Die Analyse:
(Sollten Sie mit Begriffen wie Ausdruck und WAHR und FALSCH nicht vertraut sein, lesen Sie bitte zuerst den Artikel zur Wenn Funktion durch)

Der Aufbau der ODER Funktion:

ODER(Ausdruck;Ausdruck;...)

Ausdruck muss hier immer etwas sein, was Excel als Wahr oder Falsch auswerten kann.
Die Funktion selbst gibt wieder Wahr oder Falsch zurück.
ODER(4>3;5<7)
ODER(b2>100;b3<500;Max(c2:c4)< Min(d13:d44)) etc...

Excel wertet die einzelnen Ausdrücke innerhalb der ODER Funktion aus und berechnet dann das Ergebnis für die ODER Funktion, welches immer nur WAHR oder FALSCH sein kann.
Dieses kann ich dann z.B. wunderbar als Bedingung in der Wennfunktion einsetzen, denn diese will ja etwas haben, was sie wiederum als Wahr oder Falsch auswerten kann.

Aber wann gibt nun die ODER Funktion WAHR und wann gibt sie FALSCH zurück?

Auch diese Frage ist einfach zu beantworten:
Wenn mindestens ein Ausdruck innerhalb der ODER Funktion WAHR ergibt, wird die gesamte ODER Funktion wahr, sonst falsch. (Im "Gegensatz" zur UND Funktion)

Anders ausgedrückt: Bei Verknüpfungen mit ODER muss mindestens ein Argument wahr sein, damit ODER Wahr wird. Eine kleine Tabelle:

 
 ABCDEFG
1       
2 Zwei Argumente    
3 WAHRFALSCH ergibtWAHR  
4 FALSCHWAHRergibtWAHR  
5 FALSCHFALSCHergibtFALSCH  
6 WAHRWAHRergibtWAHR  
7       
8 Drei Argumente    
9 WAHRFALSCH FALSCH ergibtWAHR 
10 WAHRWAHRFALSCH ergibtWAHR 
11 WAHRFALSCH WAHRergibtWAHR 
12 FALSCHFALSCH WAHRergibtWAHR 
13 FALSCHWAHRFALSCH ergibtWAHR 
14 FALSCHWAHRWAHRergibtWAHR 
15 FALSCHFALSCH FALSCHergibtFALSCH 
16 WAHRWAHRWAHRergibtWAHR 
17       
 
etc...
Lässt sich natürlich beliebig fortsetzen.
Wenn mindestens ein Ausdruck innerhalb einer ODER Funktion WAHR ist, liefert die ODER Funktion WAHR zurück, sonst FALSCH


Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Dieses Thema hat weitere Beiträge

ODER
UND
WENN

Weitere Artikel der Gruppe: Funktionen Aus Excel Standard
Nach oben