Autor: Peter Haserodt  --- Aus Excel Standard - Gruppe: Funktionen

UND

Autor: Peter Haserodt - Erstellt: ?      - Letzte Revision: ?Gruppenthema: 3 Folgen 1 2 3 Sie sind in Folge:2
Die UND Funktion - Nach dem Motto, wer will schon viele Wenns

Die UND Funktion ist eine Funktion, die eine logische Aussage zurückgibt, nämlich WAHR oder FALSCH.
Diese Aussage können wir dann in anderen Funktionen weiterverwerten.

Gegeben sei die Aufgabe, 3 Zellwerte auf bestimmte Inhalte zu überprüfen und zu ermitteln, ob unsere Bedingungen zutreffen.

Uns interessiert z.B., ob B2 > 4 und B3 > 5 und B4 > 6 ist. Nur wenn alle diese Bedingungen zutreffen, wollen wir in D2 das Wort Gut stehen haben, sonst das Wort Schlecht.

Der gestählte Wenn Funktion Anwender wird natürlich sofort loslegen und solch einen Konstrukt hinzaubern:
 
 ABCDE
1     
2 7 Schlecht 
3 6   
4 5   
5     
Formeln der Tabelle
D2 : =WENN(B2>4;WENN(B3>5;WENN(B4>6;"Gut";"Schlecht");"Schlecht");"Schlecht")
 

Ein fürchterlich Ding oder? Kein Mensch blickt mehr durch und wehe es werden noch mehr Bedingungen.

Will ich mehrere Bedingungen überprüfen, die ALLE wahr sein müssen, gibt es dafür die UND Funktion:

 
 ABCDE
1     
2 7 Schlecht 
3 6   
4 5   
5     
Formeln der Tabelle
D2 : =WENN(UND(B2>4;B3>5;B4>6);"Gut";"Schlecht")
 

Sieht doch eleganter aus oder?

Die Analyse:
(Sollten Sie mit Begriffen wie Ausdruck und WAHR und FALSCH nicht vertraut sein, lesen Sie bitte zuerst den Artikel zur Wenn Funktion durch)

Der Aufbau der UND Funktion:

UND(Ausdruck;Ausdruck;...)

Ausdruck muss hier immer etwas sein, was Excel als Wahr oder Falsch auswerten kann.
Die Funktion selbst gibt wieder Wahr oder Falsch zurück.
Und(4>3;5<7)
Und(b2>100;b3<500;Max(c2:c4)< Min(d13:d44)) etc...

Excel wertet die einzelnen Ausdrücke innerhalb der UND Funktion aus und berechnet dann das Ergebnis für die UND Funktion, welches immer nur WAHR oder FALSCH sein kann.
Dieses kann ich dann z.B. wunderbar als Bedingung in der Wennfunktion einsetzen, denn diese will ja etwas haben, was sie wiederum als Wahr oder Falsch auswerten kann.

Aber wann gibt nun die UND Funktion WAHR und wann gibt sie FALSCH zurück?

Auch diese Frage ist einfach zu beantworten:
Nur wenn alle Ausdrücke innerhalb der UND Funktion WAHR ergeben, wird die gesamte UND Funktion wahr, sonst falsch. (Im "Gegensatz" zur ODER Funktion)

Anders ausgedrückt: Bei Verknüpfungen mit UND müssen alle Argumente wahr sein, damit UND Wahr wird. Eine kleine Tabelle:

 
Zwei Argumente   
WAHRFALSCH ergibtFALSCH 
FALSCHWAHRergibtFALSCH 
FALSCHFALSCHergibtFALSCH 
WAHRWAHRergibtWAHR 
     
Drei Argumente   
WAHRFALSCH FALSCH ergibtFALSCH
WAHRWAHRFALSCH ergibtFALSCH
WAHRFALSCH WAHRergibtFALSCH
FALSCHFALSCH WAHRergibtFALSCH
FALSCHWAHRFALSCH ergibtFALSCH
FALSCHWAHRWAHRergibtFALSCH
FALSCHFALSCH FALSCHergibtFALSCH
WAHRWAHRWAHRergibtWAHR
 

Diese liese sich auch noch fortsetzen aber das Prinzip sollte klar sein.

Nur wenn alle Ausdrücke innerhalb einer UND Funktion WAHR sind, liefert die UND Funktion WAHR zurück, sonst FALSCH


Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Dieses Thema hat weitere Beiträge

ODER
UND
WENN

Weitere Artikel der Gruppe: Funktionen Aus Excel Standard
Nach oben