Autor: Beate Schmitz  --- Aus Excel Standard - Gruppe: Spezielle Menübefehle

Datenmaske

Autor: Beate Schmitz - Erstellt: 2005-11      - Letzte Revision: ?
Datenmaske

Die Datenmaske ist ein Excel-Bordmittel, mit dem einzelne Datensätze (stehen in einer Zeile) einer Datenbank (die sich in einem Tabellenblatt befindet) in einem Dialogfeld aufgerufen, erfasst, gesucht, gelöscht oder geändert werden können. Neben den Datenfeldern, die der Spaltenüberschrift entsprechen, enthält die Maske eine Bildlaufleiste zur Navigation durch die Datensätze sowie Buttons, um die verschiedenen Aktionen auszuführen.

Ein kleiner Hinweis:

Die Datenmaske ist ein mehr oder weniger unvollkommenes Instrument. Ich stelle es hier vor, weil es nunmal in Excel vorhanden ist. Jeder muss für sich selbst entscheiden, ob es für ihn der Weisheit letzter Schluss ist.

Wie sollte die Tabelle strukturiert sein?
  • in der Zeile 1 sollten die Überschriften der Datenbank stehen. Excel geht nämlich automatisch davon aus, dass die Datenbank in A1 beginnt. Ansonsten findet Excel die Datenbank nur, insofern sich beim Aufruf der Maske der Cursor im Bereich der Datenbank befindet. Bei Problemen, dass Excel die Datenbank findet, empfiehlt sich die Zuweisung des Namens Datenbank wie unten beschrieben
  • in den darunter liegenden Zeilen befinden sich lückenlos die Datensätze
  • die Formatierung der Tabelle nehmen Sie wie gewohnt in der Tabelle vor
  • die Datenmaske übernimmt jede Spaltenüberschrift als Feld, wobei ihre Obergrenze bei 32 Spalten liegt
  • Zellen, die keine Formeln enthalten, können Sie über die Datenmaske bearbeiten
  • Zellen, die Formeln enthalten, geben in der Maske das Formelergebnis wieder, können dort jedoch nicht bearbeitet werden. Die Formeln sind nur in der Tabelle zu bearbeiten
  • planen Sie eine Datenbank, die Formeln enthalten soll, erfassen Sie den ersten Datensatz mit Formeln am Besten direkt in der Tabelle. Ab dem zweiten Datensatz verwendet die Maske dann die Formel aus dem jeweilig darüber liegenden Datensatz. Dies hat den Vorteil, dass Sie die Tabelle nicht "auf Vorrat" mit Formeln befüllen müssen
  • pro Spalte sollte nur eine Formel in den Datensätzen sein, sonst kann Excel nicht damit umgehen.
Hier eine Beispieltabelle für die Struktur:
  • Spalten A, E und F enthalten Formeln und befüllen sich automatisch bei Erfassung
  • die Felder für die Spalten B, C und D sind in der Maske auszufüllen
 
 ABCDEF
1Nr.NameDatumNettowertMwSt.Bruttowert
21Name115.02.200555,42 €8,87 €64,29 €
32Name213.03.200566,78 €10,68 €77,46 €
43Name308.04.200572,17 €11,55 €83,72 €
54Name404.05.200562,15 €9,94 €72,09 €
65Name530.05.200553,89 €8,62 €62,51 €
Formeln der Tabelle
A2 : =TEILERGEBNIS(3;B$2:B2)*1
E2 : =RUNDEN(D2*16%;2)
F2 : =SUMME(D2:E2)
A3 : =TEILERGEBNIS(3;B$2:B3)*1
E3 : =RUNDEN(D3*16%;2)
F3 : =SUMME(D3:E3)
A4 : =TEILERGEBNIS(3;B$2:B4)*1
E4 : =RUNDEN(D4*16%;2)
F4 : =SUMME(D4:E4)
A5 : =TEILERGEBNIS(3;B$2:B5)*1
E5 : =RUNDEN(D5*16%;2)
F5 : =SUMME(D5:E5)
A6 : =TEILERGEBNIS(3;B$2:B6)*1
E6 : =RUNDEN(D6*16%;2)
F6 : =SUMME(D6:E6)
 

Zum Blattanfang

Startet man die zu dieser Tabelle gehörende Datenmaske, öffnet sie sich, den ersten Datensatz anzeigend:




Zum Blattanfang

Namenszuweisung für den Datenbankbereich

Um sicherzustellen, dass Excel Ihre Datenbank immer findet, können Sie den Bereich über Namensdefinition festlegen:
  • markieren Sie dafür diese Spalten
  • gehen über Menü > Einfügen > Namen > Namen definieren...
  • vergeben Sie den Namen: Datenbank (bzw. database in der US-Version)
  • durch die vorherige Markierung der Spalten steht der korrekte Bereich schon unter bezieht sich auf
  • Hinzufügen-Button klicken und das Dialogfenster mit OK verlassen
Wenn Sie möchten, dass nicht alle Spalten als Felder in die Datenmaske einfließen, dann markieren Sie die Spalten, die einfließen sollen und definieren den Namen wie oben beschrieben. Voraussetzung ist jedoch, dass die Spalten am Stück liegen.

Sie können Felder aber auch aus der Maske ausschließen, indem Sie die entsprechenden Spalten im Tabellenblatt ausblenden. Das funktioniert auch, wenn Sie sich im namensdefinierten Bereich "Datenbank" befinden. Nebenerscheinung ist, dass das Dialogfenster der Maske größer erscheint, als nötig.

Wie kann man Fehleingaben abfangen?

Es empfiehlt sich nicht, Eingabemöglichkeiten über Gültigkeit einzuschränken, da das insofern fehlerträchtig ist, da das Ergebnis von verschiedener Reaktion der Anwender abhängt. Also sollte man auf den Abfang von Fehleingaben verzichten.
Empfehlenswert dagegen ist der Einsatz der bedingten Formatierung , um z.B. auf Erfassungsfehler in der Tabelle aufmerksam zu machen.

Aufruf der Datenmaske:

Bis Excel 2003:
Davon ausgehend, dass Sie Ihre Tabelle gemäß obiger Struktur aufgebaut haben und bereits mindestens ein Datensatz in der Tabelle ist:
  • falls sie keinen Namen "Datenbank" definiert haben, setzen Sie den Cursor in den Bereich der Datenbank
  • gehen sie zum Aufruf der Maske über Menü > Daten > Maske...., damit springt das Dialogfeld auf
In Excel 2007:
Wurde die Datenmaske als Menüpunkt vergessen, aber sie ist zumindest noch durch folgende Tastenkombination aufrufbar, wenn der Cursor in der Tabelle steht: [ALT]+[N]+[M]

Zum Blattanfang

Daten erfassen

  • klicken Sie auf den Button Neu und füllen die Felder mit den Daten des zu erfassenden Datensatzes auf, mit der Maus oder der Tab-Taste bewegen Sie sich zwischen den Eingabefeldern, mit Enter hängen Sie den Datensatz an Ihre Datenbank an
  • wollen Sie weitere Datensätze erfassen, klicken Sie auf den Neu-Button
  • nach Erfassung des letzten Datensatzes klicken Sie auf den Schließen-Button und verlassen somit die Maske

Zum Blattanfang

Navigation in der Maske und Suche von Datensätzen

Die Navigation in der Maske können Sie über die Bildlaufleisten aber auch über die Buttons Vorherigen suchen (geht einen Datensatz pro Klick nach oben) oder Weitersuchen (geht zum nächsten Datensatz).

Zur Suche klicken Sie auf den Button Kriterien. Damit leeren sich alle Felder in der Maske inkl. der Felder, die Formeln enthalten und bei Erfassung nicht zu bearbeiten sind. Nun können Sie in ein oder mehrere Felder die Begriffe/Werte eingeben, nach denen Sie suchen möchten z.B. Artikelnummern. Für die Suche können Sie auch Platzhalter einsetzen. Nach Drücken von Enter wird der erste Treffer in der Maske ausgegeben. Durch Klick auf den Weitersuchen-Button können Sie sich die anderen Datensätze, die die Suchkriterien erfüllen, anzeigen lassen. Klicken Sie auf den Maske-Button, um den Suchmodus zu verlassen.


Zum Blattanfang

Löschen von Datensätzen

Nachdem Sie den zu löschenden Datensatz per Suche oder Navigation in der Maske angezeigt bekommen, klicken sie auf den Löschen-Button und bestätigen die dann erfolgende Rückfrage mit OK.

Zum Blattanfang

Ändern von Datensätzen

Nachdem Sie den zu löschenden Datensatz per Suche oder Navigation in der Maske angezeigt bekommen, überschreiben Sie die Feldinhalte, die sie ändern möchten. Die Änderung wird mit Enter abgeschlossen und wirkt sich in dem Augenblick in der Tabelle aus. Solange die Änderung noch nicht abgeschlossen ist, kann der ganze Datensatz über den Wiederherstellen-Button rekonstruiert werden.

Ändern von Formeln, Formaten und Feldbeschriftungen

Spaltenüberschriften (die ja die Feldbeschriftungen in der Maske sind) sowie Formeln ändern Sie nicht über die Maske sondern in der Tabelle selbst. Ebenso nehmen Sie dort die Formatierung vor.


Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Weitere Artikel der Gruppe: Spezielle Menübefehle Aus Excel Standard
Nach oben