Autor: Peter Haserodt  --- Aus Excel Standard - Gruppe: Häufige Fragen

Sinus

Autor: Peter Haserodt - Erstellt: ?      - Letzte Revision: ?
Sinusfunktion - Berechnung über Bogenmaß und andere Hindernisse

Einfach gleich ein Kurzbeispiel:

 
 ABCD
1    
2 900,89399666 
3 901 
4    
Formeln der Tabelle
C2 : =SIN(B2)
C3 : =SIN(B3*PI()/180)
 


Wir sehen, dass die Formel in C2 eine seltsamen Wert zurückgibt, während in C3 der erwartete Wert steht.
Der Sinus von 90° ist nunmal 1.

Dies liegt daran, dass Excel trigonometrische Funktionen über Bogenmaß berechnet.

Eine kurze Erklärung:


Der Umfang des Einheitskreises mit einem Radius von 1 entspricht 2PI (2 PI * r).
Stelle ich dies 360° gegegenüber so gilt:
360° <=> 2PI


1° entspricht also 360/(2*PI)

Dies kann ich noch wunderbar mit 2 kürzen also:
1° entspricht 180/PI


Somit läßt sich die Formel in C3 erklären: 1° = 180/PI dann 90° = 90 * dem Ausdruck also 90*PI/180
Und in Excel setzen wir die Exceleigene Funktion PI() ein, die PI zurückgibt.
Bei wem diese nicht zur Verfügung steht, der muss halt mit einer Konstanten arbeiten etwa:3,14159265

Aber wie entsteht der Wert in C2?


Das ist auch ganz einfach zu erklären:
2Pi entsprechen 6,28318531
Wenn ich jetzt so oft von 90 diese Zahl abziehe, bis eine Zahl übrigbleibt, die kleiner ist:
14 * 6,28318531 = 87,9645943
90 - 87,9645943 = 2,0354057 und davon der Sin im Bogenmass ist: 0,89399666
2,0354057 PI entsprechen ??? jawoll: /PI*180 also : 116,620156°

Interner Tipp:
Eine Excel Schulung von einem Profi ist Gold wert!
Peter Haserodt bietet Ihnen das und noch viel mehr...
Mehr dazu unter: Schulung

Es gibt nochetwas zu beachten: Runden

Wie Sie im unteren Beispiel sehen, erhalte ich in Zelle C2 einen anmutigen Wert.
Dies ist einfach eine Näherung an 0. Excel kann dies nicht richtig auflösen (liegt aber nicht an Excel)

Deshalb meine Empfehlung, trigonometrische Funktionen immer mit Runden zu verwenden und 10 Stellen hinter dem Komma sollten funktionieren, müssen Sie aber für sich selber austesten!
 
 ABCD
1    
2 1801,2251E-16 
3 1800 
4    
Formeln der Tabelle
C2 : =SIN(B2*PI()/180)
C3 : =RUNDEN(SIN(B3*PI()/180);10)
 


Zum Abschluss:

Das Beschriebene gilt weitgehend für die trigonometrischen Funktionen in Excel.
Weiteres dazu finden Sie dann aber in der Online-Hilfe und mit dem Erklärten sollte diese dann verständlich werden.
Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Weitere Artikel der Gruppe: Häufige Fragen Aus Excel Standard
Nach oben