Autor: Peter Haserodt  --- Aus Excel Standard - Gruppe: Funktionen

Index und Vergleich

Autor: Peter Haserodt - Erstellt: ?      - Letzte Revision: ?
Vergleich und Index sind vom Prinzip her Matrix Funktionen

Sie sollten mit Zeilen - und Spaltenbezügen in Matrizen vertraut sein.
Sonst empfehle ich ihnen erst mal das Matrix - Tutorial

Da Vergleich und Index sehr oft zusammenspielen, beide in diesem Artikel.

Und ganz brutal sm4 (1K) anhand eines einzigen Beispiels (Da Sie ja matrix-gestärkt sind)

Gesucht ist die Schnittstelle von zwei Suchwerten.
Das Beispiel sollte es zeigen.
Was steht an der Kreuzung von Äpfel und März?

Sie sollten als erstes die Tabelle nachbauen.

 
 ABCDEF
1      
2      
3  JanuarFebruarMärz 
4 Äpfel122588 
5 Birnen263399 
6      
7 Suche    
8 ObstÄpfel   
9 MonatMärz   
10      
11 Suche aufgeteilt 
12  Vergleich Index Ergebnis: 
13 Obst:1 88 
14 Monat:3  
15      
16  Zusammengefasst: 
17  88 
18   
19      
Formeln der Tabelle
C13 : =VERGLEICH(C8;B4:B5;0)
E13 : =INDEX(C4:E5;C13;C14)
C14 : =VERGLEICH(C9;C3:E3;0)
C17 : =INDEX(C4:E5;VERGLEICH(C8;B4:B5;0);VERGLEICH(C9;C3:E3;0))
 


Beginnen wir mit Vergleich:

Vergleich ist eine Funktion, welche die POSITION eines Wertes in einer Matrix findet.
Sie gibt also nicht einen Inhalt zurück, sondern eine Zahl, welche für die Position steht.

Ich möchte Sie hier nicht mit der Syntax langweilen, diese können Sie aus der OH schnell erlesen.
Wer einmal mit Matrix und auch der Funktionalität des SVerweise vertraut ist, erkennt schnell den dritten optionalen Parameter, welcher 0 für genaue Suche steht.

Viel wichtiger ist zu verstehen, dass Vergleich die Zeilen - oder Spaltenposition innerhalb meiner zu untersuchenden Matrix zurückgibt.

In unserem Beispiel untersuchen wir in Zelle C13:
=VERGLEICH(C8;B4:B5;0)
wobei C8 hier nur den Suchwert beinhaltet also Äpfel.

Diese Funktion heißt nichts anderes: Durchsuche die Matrix B4:B5 und gib mir die Position zurück, an welcher du Äpfel findest. In unserem Beispiel an Position 1

Damit haben wir auch gleich Zelle C14 erklärt!
Sie gibt mir die Position 3 für März zurück.

Interner Tipp:
Eine Excel Schulung von einem Profi ist Gold wert!
Peter Haserodt bietet Ihnen das und noch viel mehr...
Mehr dazu unter: Schulung

Index - Hier als Matrix

Die Index-Funkton gibt es in 2 Varianten. Ich beschränke mich hier auf die Matrix-Variante.

Tatsächlich ist die Index-Funktion absolut simple, wenn man mal den Matrix-Gedanken verstanden hat.
Ich gebe eine Matrix an, die Zeilenposition innerhalb der Matrix, die Spaltenposition innerhalb der Matrix und erhalte den Wert, der dort steht.

Betrachten wir uns den ersten hellblauen Bereich C4:E5:
Jeder einzelne Wert innerhalb dieses Bereiches ist über seine Zeilen - und Spaltenposition ansprechbar.

Zeile 2 Spalte 3 entspricht hier also z.B. dem Wert 99.

Zeile 1 Spalte 3 entspricht hier also z.B. dem Wert 88.

Und merken Sie etwas? Das ist schon der ganze Zauber !!!

Und jetzt alles zusammen!

Sie sollten jetzt sehen, wie 3 verschiedene Bereiche miteinander in Verbindung treten.

Wir haben eine sogenannte Kreuztabelle und der hellblaue Bereich ist der Wertebereich,
der grüne die Zeilenüberschriften und der gelbe die Spaltenüberschriften.

Über meine beiden Verweisfunktionen finde ich jeweils die Zeilen - und Spaltenposition in meinem hellblauen Bereich anhand der Überschriften.

Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Weitere Artikel der Gruppe: Funktionen Aus Excel Standard
Nach oben