Siehe auch: | Matrix als Werte | 

Autor: Peter Haserodt  --- Aus Excel Standard - Gruppe: Tutorials

Matrix Station (6) - Kurzaufenthalt Technik

Autor: Peter Haserodt - Erstellt: ?      - Letzte Revision: ?Gruppenthema: 7 Folgen 1 2 3 4 5 6 7 Sie sind in Folge:6
Technik bei Matrix - Was geht denn jetzt hier ab ?

Nun, einfach ein bisserl Hilfreiches zum weitermachen.

Station 6: Kurzaufenthalt Technik

Wie Sie sicherlich schon leidvoll erfahren haben, kann man in der Ergebnismatrix nicht einfach nur eine Zelle bearbeiten,
sondern muß den ganzen Bereich bearbeiten.

Um sich dies zu vereinfachen, markiert man einfach eine Zelle der Matrix und nimmt die Tastenkombination:
STRG+Shift+7 (Auf der normalen Tastur also den / mit Strg)

Auflösen von ...
Für das Weitere brauchen wir 2 Tasten: Einmal die Taste F9 und ganz wichtig die ESC Taste.

Ein schmerzloser Einstieg:
Stellen Sie folgende Matrixberechnung her:
 
 ABCDE
1     
2 21012 
3 32023 
4 43034 
5     
Formeln der Tabelle
D2 : {=B2:B4+C2:C4}
D3 : {=B2:B4+C2:C4}
D4 : {=B2:B4+C2:C4}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 

Markieren Sie nun eine Zelle in der Ergebnismatrix z.B. die Zelle D3. Klicken Sie nun in die Bearbeitungszeile in der steht dann im Moment folgendes:
=B2:B4+C2:C4
(Sobald Sie in die Bearbeitungszeile klicken, sehen Sie die geschweiften Klammern nicht mehr)
Betätigen Sie nun die Taste F9 und Sie sehen:
={12;23;34}
Tatsächlich wurde die Formel in ihr Ergebnis aufgelöst. Und zwar in ihr Matrix Ergebnis.
Drücken Sie nun die ESC Taste und der ursprüngliche Zustand wird wieder hergestellt!

Wir gehen wieder in die Bearbeitungszeile und markieren nur den Teil: B2:B4 (von =B2:B4+C2:C4) und wieder F9.
Sie sehen jetzt folgendes:
={2;3;4}+C2:C4
Jetzt wurde mir der Bereich B2:B4 nach seinen Werten aufgelöst.
Mit der ESC - Taste stelle ich den Ursprungszustand wieder her.

Experimentieren Sie nun ein wenig damit.

Das Auflösen in der Bearbeitungsleiste ist fundamental für das Verständis von Matrixformeln:

Schnell mal die Zahlen 1-10 zusammenzählen ?
Aber kein Problem für uns Matrixler:
 
 ABC
1   
2 55 
3   
Formeln der Tabelle
B2 : {=SUMME(ZEILE(1:10))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 
Dies jetzt nachzuvollziehen kann etwas mühsam sein.
Wenn ich aber die Zelle B2 markiere, dann in die Bearbeitungszeile klicke, sehe ich dort:
=SUMME(ZEILE(1:10))
Markieren Sie dort nun dort den Teil ZEILE(1:10) - etwas tricky - und dann F9 und schon sehen Sie:
=SUMME({1;2;3;4;5;6;7;8;9;10})
und es wird einiges klarer.
(Wenn es nicht funktioniert haben Sie nicht richtig markiert: vom Z bis einschließlich der Klammer hinter der 0)
Vergessen Sie nicht die ESC Taste.

Hinweis:

Wenn Excel die Formel nicht auflösen kann, weil es zuviele Elemente sind, erhalten Sie von Excel einen Hinweis darauf.

Na, das war doch wirklich kurz und hat kaum wehgetan! sm3 (1K)
Aber auch hier empfehle ich ihnen, eingehend damit zu testen.

Macht es noch Spaß?

Dann sehen wir uns wieder bei der Endstation.
Zur Endstation >>
Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter


Weitere Artikel der Gruppe: Tutorials Aus Excel Standard
Nach oben