Siehe auch: | Zählenwenns - ab E2007 | 

Autor: Peter Haserodt  --- Aus Excel Standard - Gruppe: Funktionen

Summewenns - ab E2007

Autor: Peter Haserodt - Erstellt: 2012-11-28      - Letzte Revision: ?

SUMMEWENNS

Sie sollten schon in der Überschrifft das große S bemerken.
Richtig, wir sprechen hier über die Funktion SUMMEWENNS und nicht SUMMEWENN!
Ich habe mich schon bei Zählenwenns darüber aufgeregt, wie verblödet es ist, einfach ein s an einen Funkionsnamen zu hängen.
Möglichst so, damit man die beiden so wenig wie möglich unterscheiden kann.
Kommen wir aber zum Thema und gleich vorneweg:

SUMMEWENNS steht erst ab Excel 2007 zur Verfügung!

Ich gehe davon aus, dass Sie die Funktion SUMMEWENN - also die ohne das S - beherrschen oder zumindest kennen. Wenn nicht empfehle ich Ihnen zuerst: SUMMEWENN

SUMMEWENNS unterscheidet sich von SUMMEWENN in den Argumentpositionen und natürlich darin, dass ich mehrere Kriterien/Kriterienbereiche habe.
Der allgemeine Konstrukt:

SUMMEWENNS(Summe_Bereich; Kriterien_Bereich1; Kriterien1; [Kriterien_Bereich2; Kriterien2]; ...)
vergleichen wir dazu SUMMEWENN:
SUMMEWENN(Bereich; Kriterien; [Summe_Bereich])

Während in SUMMEWENN der Summe_Bereich noch optional war und dem Bereich entsprechen konnte (Bereich in welchem die Kriterien gesucht werden) hat sich das in SUMMEWENNS gedreht!
Hier muss Summe_Bereich angegeben werden und zwar als erstes Argument. Das ist auch notwendig, da in SUMMEWENNS mehrere Kritierenbereiche existieren können.

In SUMMEWENNS benötigen wir also genau 1 mal Summe_Bereich - der Bereich, in welchem unsere Werte stehen, die summiert werden sollen - und n -Mal die Paarung Kriterirenbereich und Kriterien (mindestens 1 Mal)

Anhand eines einzigen Beispieles möchte ich Ihnen SUMMEWENNS näherbringen. Ja, auch ich bin geizig geworden.

 ABCDEFGHI
1     Suche  
2 MonatLandUmsatz MonatLand Ergebnis
3 MärzLand 11 MärzLand 2 12
4 FebruarLand 22     
5 FebruarLand 13     
6 MärzLand 24     
7 MaiLand 25     
8 FebruarLand 26     
9 FebruarLand 27     
10 MärzLand 28     
11         

Formeln der Tabelle
ZelleFormel
I3=SUMMEWENNS(D3:D10;B3:B10;F3;C3:C10;G3)


Betrachten wir uns zuerst die Anforderung:
Aller Umsatz soll summiert werden von Monat März und Land 2.
Unser Summe_Bereich ist klar: der grüne Bereich.
Danach arbeiten wir mit 2 Untersuchungen, nämlich den gelben Bereich auf den Monat zu untersuchen und den blauen Bereich auf das Land.
Nur wenn für beide Bereiche unser jeweils gefordertes Kriterium WAHR ist, soll Excel den Umsatz in's Töpfchen werfen.
Betrachten wir es uns nochmal anders:

WAHRFALSCH1
FALSCHWAHR2
FALSCHFALSCH3
WAHRWAHR4
FALSCHWAHR5
FALSCHWAHR6
FALSCHWAHR7
WAHRWAHR8


Nur wenn alle Bedingungen wahr sind, wird der Summe_Bereich aufgenommen. Selbstverständlich kann man dies auch noch um weitere Kriterienbereiche + Kriterien erweitern.
Und ich denke, damit sollte dem SUMMEWENN Geübten auch SUMMEWENNS geläufig werden.

Aber Aber ...

Brauchen wir das wirklich?

Zurecht wird der erfahrene Formelverdreher sagen - Sapperlot, dass kann ich doch auch über Summenprodukt erreichen.
(Für die Neugierigen unter Ihnen - hoffentlich viele: =SUMMENPRODUKT((B3:B10=F3)*(C3:C10=G3)*D3:D10))

Aber ändern wir die Anforderung ein wenig:
 ABCDEFGHI
1     Suche  
2 MonatLandUmsatz MonatLand Ergebnis
3 MärzLand 11 M*Land 2 17
4 FebruarLand 22     
5 FebruarLand 13     
6 MärzLand 24     
7 MaiLand 25     
8 FebruarLand 26     
9 FebruarLand 27     
10 MärzLand 28     
11         

Formeln der Tabelle
ZelleFormel
I3=SUMMEWENNS(D3:D10;B3:B10;F3;C3:C10;G3)

Hier wollen wir alle Monate, die mit M beginen und Land 2.
Ich gebe zu, das mein Beispiel - wie so oft - völlig am gesunden Menschenverstand vorbeigeht, aber damit müssen Sie leben.
Aber es gibt durchaus Szenarien: Artikel die auf Grund von Anfangskennzeichnern einer Gruppe zugeordnet werden können usw...

Was will ich damit sagen: SUMMEWENNS hat den Vorteil zu SUMMENPRODUKT dass es mit Platzhaltern arbeitet.
Und ich denke, dass es für manche Auswertungen nicht uninteressant ist.

Ob Sie es brauchen können?
Ja woher soll ich das denn wissen? Haben Sie mich schon einmal gefragt, was ich gebrauchen kann? Interessiert ja auch niemanden. Schluchz ...
Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Weitere Artikel der Gruppe: Funktionen Aus Excel Standard
Nach oben