Autor: Peter Haserodt  --- Aus Excel Standard - Gruppe: Funktionen

Zählenwenns - ab E2007

Autor: Peter Haserodt - Erstellt: 2012-11-23      - Letzte Revision: -

ZÄHLENWENNS

Sie sollten schon in der Überschrifft das große S bemerken.
Richtig, wir sprechen hier über die Funktion ZÄHLENWENNS und nicht ZÄHLENWENN!
Welcher nicht ganz nüchterner Wortverdreher diesen Begriff geschaffen hat, wird wohl ewig im Dunkeln bleiben.
Möglichst so, damit man die beiden so wenig wie möglich unterscheiden kann.
Kommen wir aber zum Thema und gleich vorneweg:

ZÄHLENWENNS steht erst ab Excel 2007 zur Verfügung!

Ich gehe davon aus, dass Sie die Funktion ZÄHLENWENN - also die ohne das S - beherrschen oder zumindest kennen. Wenn nicht empfehle ich Ihnen zuerst: ZÄHLENWENN

ZÄHLENWENNS ist eine ganz tückische Funktion im Verständnis.
Der allgemeine Konstrukt:

ZÄHLENWENNS(Kriterienbereich1; Kriterien1; [Kriterienbereich2, Kriterien2]…)

... und betrachten wir uns dazu die Syntax von ZÄHLENWENN.
ZÄHLENWENN(Bereich;Kriterien)

Hier möchte ich auch sofort mit dem Hammer auf irgendjemandes taube Nuß ...
Warum nennt man es bei ZÄHLENWENN Bereich und bei ZÄHLENWENNS Kriterienbereich. Da denkt man doch gleich, das wäre etwas anderes. Dabei ist Bereich und Kritierienbereich bei beiden Funktionen identisch: Ganz einfach der verdameleite Bereich in dem die jeweilige Funkition nach den Kriterien suchen soll.

Sind wir aber mal soweit gekommen, können wir daraus schließen:
Die Funktion ZÄHLENWENNS verhält sich analog der Funktion ZÄHLENWENN . Benutze ich in ZÄHLENWENNS nur einmal Kriterienbereich und Kriterien ist sie mit ZÄHLENWENN identisch.
ZÄHLENWENNS wird erst dadurch zu einer neuen Funktion, indem wir mehrere Bereiche + Kriterien benutzen. Und ganz schnell die Regeln dazu:

Regel 1: Kriterienbereich und Kriterien treten immer als Paare auf. Aber das sollte selbstverständlich sein.
Regel 2: Und diese ist etwas schwieriger zu verstehen: Die Kriterienbereiche müssen vom selben Ausmaß sein. ZÄHLENWENNS ist Positionsorientiert. Mehr dazu später.
Unschuldig komm ich daher und mach euch allen das Leben schwer - und ich mache es gerne

Ich bin gnädig und präsentiere Ihnen Beispiele mit 2 Bereichen. Damit verstehen Sie es viel einfacher.
Ich zeige Ihnen 3 Formeln die sich jeweils auf den gelben und grünen Bereich beziehen. Und Sie überlegen für sich, was bei jeder Formel wohl herauskommt. Aber nicht schummeln!

1. =ZÄHLENWENNS(B2:B6;1;D2:D6;1)

2. =ZÄHLENWENNS(B2:B6;4;D2:D6;4)

3. =ZÄHLENWENNS(B2:B6;">0";D2:D6;"<6")

 ABCDE
1     
2 1 1 
3 1 2 
4 3 3 
5 4 5 
6 5 4 
7     


Bevor ich Ihnen die Auflösung gebe, die Sie sicherlich schon längst durch ausprobieren gefunden haben - ja ich kann auf Ihren PC schauen - die Logik von ZÄHLENWENNS.
ZÄHLENWENNS ermittelt das Ergebnis an jeder Position und guckt ob positionell immer wahr ist. Wenn ja, 1 ins Köpfchen. Und am Ende zusammengezählt.
Das habe ich so verklausuliert, damit Sie es ja nicht verstehen und ich ganz schlau dastehe. Im Einzelnen:

In unserem ersten Fall sagen wir: 1.Kriterium =1 für den 1.Bereich B2:B5.
Dies trifft genau für die Zellen B2 und B3 zu.
2.Kriterium = 1 und 2.Bereich ist D2:D6
Die 1 gibt es genau in Zelle D2.

Somit
WAHR>WAHR
WAHR>FALSCH
FALSCH>FALSCH
FALSCH>FALSCH
FALSCH>FALSCH


Sie sehen, nur 1 Mal ist bei beiden gleichwertigen Positionen beides WAHR.
Und somit ergibt unsere 1. Formel : 1

Gleich hinterher:
Formel 2 schaut jeweils nach dem Kriterium 4 in beiden Bereichen. Aber eine 4 kommt nirgendswo an der gleichen Postion vor.. Also das Ergebnis= 0
FALSCH>FALSCH
FALSCH>FALSCH
FALSCH>FALSCH
WAHR>FALSCH
FALSCH>WAHR

Wir haben nirgendwo ein Doppelwahr also is nix, Ende Gelände , Null 0 Nirwana oder wie wir Profis sagen: Ei - Ei

Ändern wir die Formel ein klein wenig:
=ZÄHLENWENNS(B2:B6;4;D2:D6;5)
dann hätten wir folgende Situation:
FALSCH>FALSCH
FALSCH>FALSCH
FALSCH>FALSCH
WAHR>WAHR
FALSCH>FALSCH

Und als Ergebnis eine 1.

Und nun frisch zu unserer 3.Formel:
Da gucken wir im gelben Bereich nach Zellen, deren Wert > 0 ist und im grünen Bereich nach Zellen deren Wert < 6 ist.
Und Überraschung - das Ergebnis ist 5 weil:
WAHR>WAHR
WAHR>WAHR
WAHR>WAHR
WAHR>WAHR
WAHR>WAHR

Und nun mit Dreien - aber das ist doch einfach oder?

=ZÄHLENWENNS(B2:B6;">0";D2:D6;"<6";F3:F7;"<6")
 ABCDEFG
1       
2 1 1   
3 1 2 1 
4 3 3 2 
5 4 5 3 
6 5 4 7 
7     4 
8       

An diesem Beispiel zeige ich Ihnen gleich 2 Dinge. Das bedeutet Sie müssen Multitaskingfähig sein, also eine Frau.
(Ich schreibe es ja nacheinander - also habe ich als Mann kein Problem )

Erstens sehen wir den Versatz des Blauen Bereiches. Aber wie immer im Positionsbezug: Gleiche Größe also Super.
Und wir kommen dem Verständnis für die Funktion noch näher:

WAHR>WAHR>WAHR
WAHR>WAHR>WAHR
WAHR>WAHR>WAHR
WAHR>WAHR>FALSCH
WAHR>WAHR>WAHR

Wir haben 4 mal an allen drei Positionen WAHR also ist das Ergebnis 4!


Der selbe Bereich

=ZÄHLENWENNS(B2:B6;1;B2:B6;3)

 ABC
1   
2 1 
3 1 
4 3 
5 4 
6 5 
7   


Geben Sie es zu - nun nicken Sie schon.
Hätte ich dieses Beispiel zuerst gebracht, hätten Sie die ZÄHLENWENNS Funktion gleich in die Tonne getreten.
Jetzt wissen Sie aber sofort, dass dabei nur 0 herauskommen kann - oder etwa nicht? Wenn nicht, dann beschweren Sie sich sofort beim OberNullAmt.
Doch weil es so schön ist:

WAHR>FALSCH
WAHR>FALSCH
FALSCH>WAHR
FALSCH>FALSCH
FALSCH>FALSCH


Ein weiteres Beispiel, welches etwas mehr Sinn ergibt:
 ABCD
1    
2 1 2
3 5  
4 3  
5 7  
6 6  
7 2  
8 9  
9    

Formeln der Tabelle
ZelleFormel
D2=ZÄHLENWENNS(B2:B8;">2";B2:B8;"<6")

Hier haben wir mit unserem ZählenWenns ermittelt, wieviele Werte im gelben Bereich zwischen 6 und 2 liegen.

Und jetzt die große Frage an die Gemeinde:
Wie muss ich die Formel ändern, damit die 2 und die 6 eingeschlossen sind.
Jawohl: =ZÄHLENWENNS(B2:B8;">=2";B2:B8;"<=6")
Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Weitere Artikel der Gruppe: Funktionen Aus Excel Standard
Nach oben