Siehe auch: | Zählenwenn | 

Autor: Peter Haserodt  --- Aus Excel Standard - Gruppe: Funktionen

Summewenn

Autor: Peter Haserodt - Erstellt: ?      - Letzte Revision: ?

Als ich zum ersten Mal mit Summewenn konfrontiert wurde, hatte ich Schwierigkeiten, dass System dahinter zu verstehen.
Bis es mir wie Schuppen von den Augen fiel:
Summewenn arbeitet matrixorientiert !

Der Syntax ist bekannterweise: Summewenn(Bereich;Suchkriterium;[Summe_Bereich])
Wie zu ersehen ist, ist das letzte Argument optional. Lasse ich es weg, wird der Bereich bei Summe_Bereich eingesetzt - also ich summiere über den Bereich den ich untersuche.

Aber viel wichtiger ist zu versehen, wie Bereich und Summe_Bereich miteinander in Beziehung stehen.
Schauen wir auf die Beispiele:
 
 ABCDEFGH
1        
2 Haus110100   
3 Maus211101   
4 Klaus312102   
5 Maus413103   
6 Haus514104 1 
7 Klaus615105 2 
8 Maus716106 3 
9      4 
10 SucheHaus   5 
11      6 
12 Summe aus C6   7 
13 Summe aus D24     
14 Summe aus E204     
15        
16 Summenversuch aus C D E6     
17        
18 Summe aus G6     
19        
Formeln der Tabelle
C12 : =SUMMEWENN(B2:B8;C10;C2:C8)
C13 : =SUMMEWENN(B2:B8;C10;D2:D8)
C14 : =SUMMEWENN(B2:B8;C10;E2:E8)
C16 : =SUMMEWENN(B2:B8;C10;C2:E8)
C18 : =SUMMEWENN(B2:B8;C10;G6:G12)
 


Interner Tipp:
Eine Excel Schulung von einem Profi ist Gold wert!
Peter Haserodt bietet Ihnen das und noch viel mehr...
Mehr dazu unter: Schulung

Die Ergebnisse in den Zellen C12 bis C 14 sind noch nachzuvollziehen.
Aber warum funktioniert C16 nicht und warum habe ich in C18 dieses Ergebnis obwohl der grüne Bereich doch ganz anders liegt als mein Suchbereich.
Die Lösung liegt in der Matrixorientierung!

Summewenn durchsucht den angegebenen Suchbereich auf das Suchkriterium und merkt sich Zeilen- und Spaltenindex der Fundorte, wobei dies nichts mit unseren Zeilen und Spaltenbezeichnungen zu tun hat, sondern sich rein auf den Bereich bezieht.
In unserem Beispiel findet Excel Haus an den Stellen 1,1 und 5,1 also Zeile 1, Spalte 1 des Bereiches, Zeile 5, Spalte 1 des Bereiches.

Jetzt guckt Summewenn in den zu summierenden Bereich und sucht dort die entsprechenden Positionen.

Langsam wird es klar, warum in C16 als Ergebnis 6 rauskommt:
Zwar ist der Bereich den ich summieren will größer, aber Excel interessiert dort nur Zeile 1, Spalte 1 des Bereiches, Zeile 5, Spalte 1 des Bereiches.

Und das gleiche gilt für unser Beispiel in C18, dort habe ich als zu summierenden Bereich G6:G13 angegeben und Zeile 1, Spalte 1 ist G6 und Zeile 5, Spalte 1 ist G10

Und um das ganze nun zu beweisen und ihnen noch ein bisserl den Kopf rauchen zu lassen zum Abschluss; ein weiteres Beispiel:
 
 ABCDEFG
1       
2 HausKlaus    
3 MausMaus    
4 KlausHaus    
5 MausKlaus    
6 HausMaus    
7 KlausHaus    
8 MausMaus    
9       
10 SucheHaus    
11       
12 Ergebnis:33    
13    110 
14    211 
15    312 
16    413 
17    514 
18    615 
19    716 
20       
Formeln der Tabelle
C12 : =SUMMEWENN(B2:C8;C10;E13:F19)
 
Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Weitere Artikel der Gruppe: Funktionen Aus Excel Standard
Nach oben