Autor: Beate Schmitz  --- Aus Excel Standard - Gruppe: Häufige Fragen

Monat in Zahl wandeln

Autor: Beate Schmitz - Erstellt: ?      - Letzte Revision: ?

Monat in Zahl wandeln Angenommen, Sie haben Zellen, die Monatsnamen enthalten und Sie möchten mit diesen weiterrechnen, also in die entsprechende Monatszahl wandeln. Dann ermöglicht Ihnen das diese kleine Formel, wobei es egal ist, ob der Monatsname ausgeschrieben ist oder nur die Kurzform in der Ausgangszelle vorliegt:
 ABCDE
1Monatentspricht Monat Kurzformentspricht
2Januar1 Jan1
3Februar2 Feb2
4März3 Mrz3
5April4 Apr4
6Mai5 Mai5
7Juni6 Jun6
8Juli7 Jul7
9August8 Aug8
10September9 Sep9
11Oktober10 Okt10
12November11 Nov11
13Dezember12 Dez12

Formeln der Tabelle
ZelleFormel
B2=MONAT(1&A2)
E2=MONAT(1&D2)

Die Formeln aus Zeile 2 können nach unten kopiert werden.


Ein Anwendungsbeispiel:

Sie möchten ausgeben, wieviel Stück von Artikel 2 im Feb. verkauft wurden:
 ABCDEFG
1AbsatzJanFebMrz Artikel:Artikel2
2Artikel1148 Monat:Feb
3Artikel2691 Absatz:9
4Artikel3162617   

Formeln der Tabelle
ZelleFormel
G3=SVERWEIS(G1;A2:D4;MONAT(1&G$2)+1;0)


Durch den Einbau der o.g. Formel in die SVWERWEIS-Formel können Sie somit elegant den Spaltenindex dynamisieren, wenn in der Überschrift Monate als Text stehen.


Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Weitere Artikel der Gruppe: Häufige Fragen Aus Excel Standard
Nach oben