Autor: Beate Schmitz  --- Aus Excel Standard - Gruppe: Häufige Fragen

Formelzelle soll leer erscheinen

Autor: Beate Schmitz - Erstellt: ?      - Letzte Revision: ?

Formelzelle soll leer erscheinen, wenn Bedingungen nicht erfüllt sind

Es gibt Situationen, da möchten Sie erreichen, dass ein Formelergebnis erst sichtbar wird, wenn bestimmte Bedingungen zutreffen. Um eine scheinbar leere Zelle zu erzeugen, wird die Zeichenkette "" (doppeltes Anführungszeichen) in die Formel eingebaut. Wirklich leer ist die Zelle ja nicht, denn sie enthält ja die Formel, die bei Eintreten der Bedingung(en) ein Ergebnis ausgibt.>
  • Zum Einen können Sie durch diese Technik vermeiden, dass ungewollte Ergebnisse angezeigt werden
  • Zum Anderen vermeiden Sie damit, dass Nachfolgerzellen mit diesem ungewollten Ergebnis weiterrechnen können
  • Sie können diese Technik auch einsetzen, wenn Sie Listen "auf Vorrat" mit Formeln bestücken wollen - damit Sie solange, bis Sie gebraucht werden, noch keine Null-Ergebnisse ausgeben. Diese Vorratshaltung sollten Sie aber auf ein sinnvolles Maß beschränken, um Ihre Datei nicht übermäßig aufzublähen. Bedenken Sie: Auch diese Zellen werden bei Neuberechnung mitberechnet und kosten somit Rechenzeit!
  • Oder sogar, dass Fehlerwerte ausgegeben werden, insofern die Vorgängerzellen kein sinnvolles Ergebnis ergeben. Wenn es Ihnen um die Vermeidung von Fehlerwerten geht, schauen Sie bitte auch hier: Fehlerwerte behandeln - nutzen

Wir müssen also Bedingungen überprüfen und entsprechend muss die Funktion WENN in die Formel integriert werden. Handelt es sich sogar um eine Kombination verschiedener Bedingungen kommen WENN/UND bzw. WENN/ODER in Betracht. Zum Verständnis ist auch der Beitrag UND * ODER + empfehlenswert.

Wichtig ist auch der richtige Einsatz der Vergleichsoperatoren, um das gewünschte Ergebnis zu erzielen.

Ich zeige Ihnen hier nachstehend einige einfache Beispiele, die Sie dann mit Wissen über die WENN-Möglichkeiten auf Ihre Formel übertragen können:>

Zum Blattanfang

Wenn Vorgängerzellen leer sind, soll Ergebniszelle leer erscheinen:

 ABCDEF
1      
2 D soll leer erscheinen, wenn B leer istAuswirkung 
3 5712B ist gefüllt > D nicht leer 
4 5 5B ist gefüllt > D nicht leer 
5  7 B ist leer > D leer 
6    B ist leer > D leer 
7      
8 D soll leer erscheinen, wenn B und C leer sindAuswirkung 
9 5712B und C sind gefüllt > D nicht leer 
10 5 5B ist gefüllt > D nicht leer 
11  77C ist gefüllt > D nicht leer 
12    B und C sind leer > D leer 
13      
14 D soll leer erscheinen, wenn B oder C leer istAuswirkung 
15 5712B und C sind gefüllt > D nicht leer 
16 5  C ist leer > D leer 
17  7 B ist leer > D leer 
18    B und C sind leer > D leer 
19      
20 Die Formeln können Sie jeweils nach unten kopieren! 
21      

Formeln der Tabelle
ZelleFormel
D3=WENN(B3="";"";B3+C3)
D9=WENN(UND(B9="";C9="");"";B9+C9)
D15=WENN(ODER(B15="";C15="");"";B15+C15)
Die Funktion ISTLEER können Sie ebenso zur Prüfung einer Vorgängerzelle einsetzen wie "". Hier sehen Sie, dass Beides den gleichen Effekt hat:

 ABCDEFG
1       
2 D soll leer erscheinen, wenn B leer istAuswirkungEinsatz von 
3  7 B ist leer > D leerISTLEER 
4  7 B ist leer > D leer"" 
5       

Formeln der Tabelle
ZelleFormel
D3=WENN(ISTLEER(B3);"";B3+C3)
D4=WENN(B4="";"";B4+C4)



Zum Blattanfang

Wenn Vorgängerzellen bestimmte Bedingungen nicht erfüllen, soll Ergebniszelle leer erscheinen:

 ABCDEF
1      
2 D soll leer erscheinen, wenn B kleiner 5 istAuswirkung 
3 37 B ist kleiner 5 > D leer 
4 6 6B ist größer 5 > D nicht leer 
5      
6      
7 D soll leer erscheinen, wenn B und C kleiner 5 sindAuswirkung 
8 628B ist größer 5 > D nicht leer 
9 3710C ist größer 5 > D nicht leer 
10 6713B und C sind größer 5 > D nicht leer 
11 43 B und C sind kleiner 5 > D leer 
12      
13 D soll leer erscheinen, wenn B oder C kleiner 5 sindAuswirkung 
14 37 B ist kleiner 5 > D leer 
15 62 C ist kleiner 5 > D leer 
16 43 B und C sind kleiner 5 > D leer 
17 7815B und C sind größer 5 > D nicht leer 
18      
19 Die Formeln können Sie jeweils nach unten kopieren! 
20      

Formeln der Tabelle
ZelleFormel
D3=WENN(B3<5;"";B3+C3)
D8=WENN(UND(B8<5;C8<5);"";B8+C8)
D14=WENN(ODER(B14<5;C14<5);"";B14+C14)

Zum Blattanfang

Wenn Vorgängerzellen bestimmten Text nicht enthalten, soll Ergebniszelle leer erscheinen:

Wichtig zum Erreichen korrekter Ergebnisse im Umgang mit Text ist die Beachtung von Groß- und Kleinschreibung, wenn Sie danach unterscheiden wollen. Dann müssen Sie Ihre Formeln erweitern.

Suchen Sie nur nach bestimmten Textteilen in einer Zelle, dann müssen Sie Platzhalter einsetzen. Und dies wie dort dargestellt mit der Funktion Zählenwenn kombiniert.

Wie in den obigen Beispielen dargestellt, können Sie die Bedingungen mit UND bzw. ODER erweitern.

Beachten Sie: Den Text, auf den Sie prüfen, müssen sie in Anführungszeichen in die Formel eingeben:>
 ABCDE
1     
2 C soll leer erscheinen, wenn B nicht "Hund" enthältAuswirkung 
3 HundTrefferB enthält "Hund" > C nicht leer 
4 Katze B enthält nicht "Hund" > C leer 
5     
6 Die Formel können Sie nach unten kopieren! 
7     

Formeln der Tabelle
ZelleFormel
C3=WENN(B3="Hund";"Treffer";"")


Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Weitere Artikel der Gruppe: Häufige Fragen Aus Excel Standard
Nach oben