Autor: Peter Haserodt  --- Aus Excel Standard - Gruppe: Häufige Fragen

Matrix als Werte

Autor: Peter Haserodt - Erstellt: ?      - Letzte Revision: ?

Matrix als Werte

Ein kleines Beispiel wie man eine Matrix innerhalb einer Funktion direkt angibt (also ohne Bereich)
 
 ABCDEFG
1       
2 SucheErgebnis Matrix 
3 12b 0a 
4    9b 
5    13c 
6       
7 Sverweis direkt     
8 b     
9       
Formeln der Tabelle
C3 : =SVERWEIS(B3;$E$3:$F$5;2)
B8 : =SVERWEIS(12;{0."a";9."b";13."C"};2)
 
 Ihre Meinung zu Online Excel Geben Sie uns ein Feedback
Sie sehen in Zelle B8 erhalten wir dassselbe wie in Zelle C3.
Schauen wir uns speziell den Matrixbereich an:
=SVERWEIS(12;{0."a";9."b";13."C"};2)

Eine Matrix wird innerhalb einer Funktion mit geschweiften Klammern eingegrenzt, diese muss ich selber schreiben.
(Bitte verwechseln Sie dies nicht mit Matrixformeln die geschweifte Klammern um die Formeln haben)


Spalten werden durch einen Punkt getrennt, Zeilen durch Strichpunkt.

(Dies gilt selbstverständlich für die deutsche Ländereinstellung!)


Und das wars schon
Fragen stellen im Online-Excel Forum

Neu in Online-Excel: Online-Excel Newsletter

Weitere Artikel der Gruppe: Häufige Fragen Aus Excel Standard
Nach oben